Print Page   |   Contact Us   |   Sign In   |   Register

Join Vivit
Contact Vivit
Become a Leader
Become a Sponsor
Community Search

Discovery in the Cloud: The Future of Configuration Management

Digital Transformation with HPE Cloud Management

Deliver Amazing Apps Fast in the Idea Economy: a DevOps Transformation

Virginia / Mid-Atlantic VIVIT Chapter Meeting

Chicago Chapter Webinar

LinkedInTwitterFacebookGoogle Plus

HPE Software Products: Business Process Testing
Share |

Need BPT download linkOpen in a New Window

I need BPT download link , to do a feasibility study.


Please provide best practise for 'how to use BPT in UFT'Open in a New Window

Hi Dear,
how to use Business Process Testing in UFT? And integrate Business Component, Application Area and other resource of ALM with UFT.
please provide best practise on it. Thanks.


Get an attachment from current FlowOpen in a New Window

We are struggling with the following. We have several Business (scripteds UFT) Process Components. We created several Flows in HP ALM containing Business Components. In an HP ALM Flow you also have the option to add an attachment tot that flow in the Attachment tab. 

How can we extract an attachment of a flow via HP ALM OTA code in UFT? For a Business Process Test we can get this with for example the CurrentTest attachment factory. But we can not find any attachment factory related to a Flow. Is there any way to download/extract a flow attachment with HP ALM OTA code in UFT?

Any help on this highly appreciated.



BPT - get and use current browser and pageOpen in a New Window

Hi all,

In order to test a web application I stored the objects (browsers, pages, links, ect) in repository and created a BPT containing few business components. Object (browser/page/link) name is parameterized at component level.

My question is how can I run the test (for all components) on current browser and current page without passing the browser name and page name?


P.S.: Browser("creationtime:=0").Page("micclass:=Page").Link("link_name")

will not work since my link is part of a hierarchy that looks like : Browser("br_name")->Page("pg_name")->Link("link_name")


Many many thanks!




Business processes run from ALM fail since it sees the objects as Windows as opposed to BrowserOpen in a New Window

Hi All,

There is already a post about this issue that i am facing. :"UFT BPT nightmare". But there isn't any replies/updates to that. So i am posting this issue as a new one. Here's what's happening.

I created business components in UFT, which when run from UFT, identifies my web application fine. Browser.Page....

However, when i add the business components to a Business process in 'ALM->Test Plan', and run them from ALM, the runs fail. This happens becuase now UFT (running in background) reads the web application as a Window. Can someone please advice what i might be missing? 



BPT, QTP, and ALMOpen in a New Window

Pardon my ignorance, but I am inquiring about BPT and using it with QTP. In order to do this, do I need to use ALM as well?


How to get Business component instance number from QC/ALMOpen in a New Window

Hi All,


I am working on BPT framework and for a single testcase i am using same component multiple times.


I need to fetch the Business component instance number, based on the instance number i will read the required component parameters from excel sheet.


Please help


BPT Business and Scripted Components created seperatly and later linked.Open in a New Window



We have 2 different teams

- 1st team - Create business components

- 2nd team - Create Scripted components

The business components are created first by the 1st team and then later picked up by the 2nd team for automation.


Can business components and scripted components be created seperatly and later linked to each other ?


Can the same scripted component be linked to many business components ?


Rename components at run timeOpen in a New Window

Is there a way to rename the business components at runtime with the test scenario name for each iteration?


BPTWrapperTestOpen in a New Window

Hi ,


 we are using HP ALM 11 and QTP 11 , When we are executing the BP Tests from Test Lab, it fails and no result is logged for analyzing the results. We see a quick message on BPTWrapperTest and then the test fails.


We are running the test on Remote desktop and can not disable the BPTWrapper in registry.


Is there any patch available which will allow the run the tests without disabling the wrapper test in registry ?


Remote desktop is WIndows 7 -32 bit OS


Appreciate quick response on this











Failed to Post Simple KeyOpen in a New Window

When a component is modified, say added an input parameter.

When trying to enter data for that component in BPT flow (under Test Plan in ALM), I get an error as ‘Failed to Post Simple Key’ in ALM


How can this be resolved? I had to remove that component from the BPT flow and call it again. I lose the I/O mapping references everytime.




UFT BPT nightmareOpen in a New Window

I am struggling to get UFT 11.52 SP1 working with BPT components on QC 11 Patch 15.

I have QC installed on one VM, UFT on another, I am connecting to QC via IE Browser on the UFT machine. The UFT 11.52 Patch 1 plugin for QC is installed on the UFT machine.


I can create a component remotely, record that component, and run the component successfully.


However when I come to run a test created in QC that has that component in it, it will open UFT and the component, but then not do anything. No objects are being recognised. I stop the failed test, and do an object spy, all the objects are being recognised as Window objects of type "Internet Explorer Server", not Browser objects.


Also, I am unable to associate a shared repository with the component, the option to do so is greyed out.


Anyone had UFT working with BPT? Any ideas? Does the ALM plugin have to be installed on the QC server aswell?


Enabling Next Generation Test Automation on HP ALM, HP UFT and HP BPTOpen in a New Window

Advanced Training: Mango – Enabling Next Generation Test Automation on HP ALM, HP UFT and HP BPT


Full details are at:



Error running BPT including a component automated with Service Test v11.2Open in a New Window

We are using ALM v11.0 patch 12 with Business Process Testing enabled.


A user has automated a business process component using Service Test 11.2


When the user attempts to execute the Business Process Test that includes this component, in the Automatic Runner dialog they receive this status message:


"Cannot run component BPGroupGetSet in business process test ST_OF_BPCreateViewCustomer. The version of Application Lifecycle Management does not support running components of type SERVICE-TEST-11-AUTOMATED."


Please advise - what do we need to do in order to run automated business process tests from ALM v11.0 when they include Service Test automated components?


(I have also posted this message in the ALM/QC and Service Test forums)


Free pre-conference training on Test Automation at HP Discover in Frankfurt on 3 December.Open in a New Window

Join Vivit the day before HP Discover begins for complimentary Advanced Training.


Executing BPT test through OTAOpen in a New Window

I have set of BPT test cases in a test set. I would like to run the selected test cases using "Scheduler" object through OTA API. I found "Running the test instances in a test set locally, remotely, or as planned" script in HP ALM OTA reference book. Which has the script to run the entire test set.  


However my test cases are niot executing, can someone help please ?


BPT Wrapper TestOpen in a New Window



Anyone know what checks need to be made to ensure that a BPT uses the Wrapper Test process.


I have two Tests with one Flow different between them. One will execute with the BPTWrapper and the other one won't. I assume it is something to do with one of the Components in the extra Flow.


I have run the routine to set the reusable flag on the Components in this flow so looking for any other pointers





BPT issue: QTP unable to open an ALM componentOpen in a New Window

I have an on-going issue with BPT solution, and there is already a logged HPSS ticket on this. 


However 3 months already passed, and there is still no definite solution to my problem. 

Screenshots were taken by the assigned engineer, but no clear direction yet.
I ma afraid we are not close to the resolution yet.


The problem, which i wanted to solicit help on is documented in the attached file on this post.


The problem that my current team have, when i try to open an automated component through QTP there are at  2 dialog boxes that appears. At the end, nothing is opened. 


The dialog boxes has these messages:
- Cannot find the data table file ....
-  Unexpected file format

Thanks in advance for the help and pointers.  


HP Quality Tools Vivit Meeting on March 14, 2012Open in a New Window


un-promoting test-level BPT parametersOpen in a New Window

Is there an easy way to do this or do I have to delete and re-add the component and NOT promote the parameters?



Sign In

Forgot your password?

Haven't registered yet?

Vivit Blog