HPE Software Products: UCMDB and UD Practitioners Forum (Previously CMS)
Share |

ucmdb browser guideOpen in a New Window

Hi ,

 

Anyone worked on ucmdb browser installation 4.12 on 10.21 ucmdb server

If yes , please share the guide

 

Thoughts on flipping a UCMDB tree - integration involved SMOpen in a New Window

Need to analyse and best implementation approach to flip the tree in UCMDB.   affects SM integration, tickets, change,...

Current state: bottom - up relationship (running-software, node (computer), CI (model).  example

Example 1: a Server CI has 2 applications (Customer service, broker portal) but the running software RDBMS is serving 4 applications (Customer service, Broker portal, websupport, ...).  

Desired state: bottom - up relationship (server, running-software, application)

affecting SM implementation.  best practice approach to change the relationship

see attached

 

 

 

 

 

Map results of postscan scripts to uCMDB attributesOpen in a New Window

Is anyone using postscan scripts with UD scanning (inventory discovery) and has mapped the results of postscan scripts (in DDMI this was saved in table hwAssetCustomData) to uCMDB attributes? How can this be done? More complicated, the number and names of the custom attributes collected by the postscan scripts may vary...

 

CI identification issueOpen in a New Window

Hello,

I'm having an issue with a custom CI that is based on business_application. As per the original identification rule, the CI is supposed to duplicate instead of merge when " Two BusinessApplication instances are considered to be different if they are owned by different Party objects", which is also reflected in the ident rule itself:

                <connected-ci-condition ciType="party" linkType="ownership" isDirectionForward="false" conditionType="approveAndContradict">
                    <overlap-fixed-operator number-of-matches="1"/>

I've modified my own CIT (influx_service) to look at not party, but influx_cluster (also a custom CI based on application_system CIT):

                <connected-ci-condition ciType="influx_cluster" linkType="dependency" isDirectionForward="false" conditionType="approveAndContradict">
                    <overlap-fixed-operator number-of-matches="1"/>

Other parts of the rule are identical to the factory rule of business_application, you'll notice that I only changed the CI and link type. Given this, I believe that 2 similar influx_service CI's should duplicate/separate when they have different influx_cluster objects connected to them via dependency. I'm attaching a screenshot showing this is not what happens. The unix node highlighted with a red circle is a standalone deployment of this application and creates a different influx_cluster CI called INFLUX STANDALONE, meaning that based on the ident rule, KAPACITOR and INFLUXDB should be duplicated - STANDALONE and CLUSTER should have their own set of KAPACITOR & INFLUXDB.
I'm guessing the problem is in the rule itself, although it's copied from a factory rule. Can anyone point out what I've done wrong here?

 

Unable to start Configuration Manager 11.20Open in a New Window

Hi all,

I am unable to get CM 11.20 running.
I have ucmdb up and running with no problems (in fact, I have a 11.22 and a 11.30).
I run the instalation wizard fine, all tests passed, all passwords are correct (I've checked them a thousand times).
Instalation runs, but it says it finished with 6 non-fatal errors.

I can see a few changes on uCMDB: 2 new integration points, a "amber_all" perspective, etc. These changes appeared at the same time as the installation.

Thing is, my accessing http://<hostname>:8180/cnc , I get a 404 error from tomcat. "(/cnc) is not available"

on service startup, stderr.log shows:

INFO: Deploying web application archive cnc.war
Mar 22, 2017 5:51:18 PM org.apache.catalina.core.StandardContext startInternal
SEVERE: Error listenerStart
Mar 22, 2017 5:51:18 PM org.apache.catalina.core.StandardContext startInternal
SEVERE: Context [/cnc] startup failed due to previous errors

A few seconds later, this appears:

Mar 22, 2017 5:51:19 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [/cnc] registered the JDBC driver [com.mercury.jdbc.oracle.OracleDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Mar 22, 2017 5:51:19 PM org.apache.catalina.loader.WebappClassLoader clearReferencesJdbc
SEVERE: The web application [/cnc] registered the JDBC driver [com.mercury.jdbc.sqlserver.SQLServerDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
Mar 22, 2017 5:51:19 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads

On the other hand, amber_general.log shows:

2017-03-22 17:51:18,243 ERROR User: ContextLoader.initWebApplicationContext:220 Context initialization failed

<omitted a gigantic stack trace, with multiple caused bys>

<this is the last two "caused bys'">

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'cmdbClassModelService': Invocation of init method failed; nested exception is java.lang.NoSuchMethodError: com.hp.ucmdb.api.client.RootObject.getClassModelService()Lcom/hp/ucmdb/api/classmodel/ClassModelServiceInternal;

Caused by: java.lang.NoSuchMethodError: com.hp.ucmdb.api.client.RootObject.getClassModelService()Lcom/hp/ucmdb/api/classmodel/ClassModelServiceInternal;

 

I've tried installing and pointing it to ucmdb 10.22 and 10.30, tried multiple different servers, tried reinstalling multiple times using hostnames, ips, a new dedicated MSSQL database server for it... everything.

Any ideas?

 

Excel import issue- getting failed to resolve object container errorOpen in a New Window

Hi all

attached sheet for reference i was trying to import clusterresourcegroup data with nodes but it says failed to resolve object container error.

 

<execution jobId="DS_excel import_Import topology from Excel Workbook" destinationid="befc285bf6ea48a0a6a04d124c0dece8" max_store_sent_results="2147483647">
<destination>
<destinationData name="ip_domain"></destinationData>
<destinationData name="hostId"></destinationData>
<destinationData name="id">befc285bf6ea48a0a6a04d124c0dece8</destinationData>
<destinationData name="ip_address"></destinationData>
</destination>
<params>
<param param_name="integer_list_delimiter" param_value="," />
<param param_name="JOB_ID" param_value="DS_excel import_Import topology from Excel Workbook" />
<param param_name="file_name" param_value="D:\1.xlsx" />
<param param_name="relationship_attr_delimiter" param_value="|" />
<param param_name="defaultOwner" param_value="" />
<param param_name="runInSeparateProcess" param_value="true" />
<param param_name="set_empty_value" param_value="false" />
<param param_name="taskType" param_value="regular" />
<param param_name="maxThreadRuntime" param_value="900000" />
<param param_name="remoteJVMClasspath" param_value="%minimal_classpath%;../lib/dom4j.jar;../runtime/probeManager/discoveryResources/geronimo-stax-api_1.0_spec-1.0.jar;../runtime/probeManager/discoveryResources/poi-3.7-20101029.jar;../runtime/probeManager/discoveryResources/poi-ooxml-3.7-20101029.jar;../runtime/probeManager/discoveryResources/poi-ooxml-schemas-3.7-20101029.jar;../runtime/probeManager/discoveryResources/xmlbeans-2.3.0.jar" />
<param param_name="string_list_delimiter" param_value="," />
</params>
<log start="12:30:56" severity="info">Execution current time:2017/03/22 12:30:56</log>
<log start="12:30:57" severity="debug">Excel file to process:D:\1.xlsx</log>
<log start="12:30:57" severity="debug">file D:\1.xlsx exists</log>
<log start="12:30:57" severity="debug">OXML excel format</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="info"> Process all tabs and create OSH from them; Root containers and links will be created lately</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="debug">Processing worksheet: cluster_resource_group</log>
<log start="12:30:59" severity="debug">Processing worksheet: node</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="info"> Process root containers from early created OSHes</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="debug">Processing references of worksheet: cluster_resource_group</log>
<log start="12:30:59" severity="debug">unable to resolve OSH using None</log>
<log start="12:30:59" severity="debug">unable to resolve OSH using cluster_resource_group 3</log>
<log start="12:30:59" severity="warn">failed to resolve object container</log>
<log start="12:30:59" severity="debug">Processing references of worksheet: node</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="info"> Report OSH to vector</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="debug">reported 2 objects</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="info"> Process relationships</log>
<log start="12:30:59" severity="info"> ------------------------------------------------------------------</log>
<log start="12:30:59" severity="debug"> ------------------------------------------------</log>
<log start="12:30:59" severity="debug"> Worksheet rows: 2 (including header)</log>
<log start="12:30:59" severity="debug"> ------------------------------------------------</log>
<log start="12:30:59" severity="info">Execution current time:2017/03/22 12:30:59</log>
</execution>

 

if anyone help appriciated.

 

thanks

Chethan

 

Installing UD Probe 11.30 stuck at "creating database"Open in a New Window

This has had my head scratching for a while...

I am unable to install the UD probe version 11.30, straight from the partner's portal. It always gets stuck at "Creating Dataflow probe database schemas".
And by stuck I mean 8-hours stuck on that.
I've tried on the same server where previously was the 11.22 and ucmdb, on another server, on a freshly installed VM, while standing upside down, and singing kumbaya.... No luck.

 

postgressql.log shows only this:

2017-03-21 16:48:04.443 GMT  424  LOG:  database system was shut down at 2017-03-21 16:48:01 GMT
2017-03-21 16:48:04.445 GMT  424  LOG:  MultiXact member wraparound protections are now enabled
2017-03-21 16:48:04.449 GMT  3452  LOG:  database system is ready to accept connections
2017-03-21 16:48:04.458 GMT  1548  LOG:  autovacuum launcher started

(only these 4 lines)

 

probesetup.log:

Running C:\hp\UCMDB\DataFlowProbe\tools\dbscripts\createProbeDBs.cmd at Tue 03/21/2017 16:48:06.05

(just this ONE line). It has started at 21th march, 4:48 PM, and is now 22nd march, 10:45am and still no development.... ARGH.

Any new ideas?

 

uCMDB Browser 4.12 export errorOpen in a New Window

We're running our uCMDB Browser (version 4.12) on a standalone server, connected to uCMDB 10.22. I've created a report that lists multiple nodes as well as related IP nodes. When I try to export the file to anything other than an xml file I get the following error:

"Export An error has occurred. The url to the generated file is null."

Up until this week we were still using the native browser on the application server which was version 4.01 I believe. We got the same error on there.

I have found a couple workarounds for a Linux install but have not found any for a Windows install. We are running on Server 2012 R2. One workaround was to add the Arial font to the Linux OS, the other was to ignore the missing font. I have not found where to set this.

Any assistance would be appreciated.

 

UCMDB cannot connect to an ORACLE existing schemaOpen in a New Window

After successfully deployment of UCMDB version 10.22 and creaion of an ORACLE schema, I cannot connect to the existing created ORACLE schema because of the follwoing error:

Cannot connect to schemas"
Cmdb server version setting: upgrader.cmdb is = [] (therefore is different than the server version [10.22])
because this schema didnt pass a successful upgrade / package deployment"

More details attached.

Thanks,

 

Next UCMDB Online Expert day April 26-27thOpen in a New Window

Hello Everyone,

CMS (UCMDB/UD)  is hosting an Online Expert Day on April 26-27th, 2017!  Mark this on your calendars! 

If you are a customer with a support contract, then we would like to invite you to join us UCMDB and UD Support Customer Forum  on April 26-27th , when HPE product Experts will be online for 24 hours to answer any questions regarding:

Any topic on UCMDB

 

Event start time: April 26th at 02:00 AM Pacific Daylight Time / 5:00 AM Eastern Daylight Time / 9:00 AM Greenwich Mean Time

Event end time: April 27th at 02:00 AM Pacific Daylight Time / 5:00 AM Eastern Daylight Time / 9:00 AM Greenwich Mean Time

 

What is an Online Expert Day? 

Online Expert Day is an event when HPE product, R&D, and Support team members and other employees join our online forums to answer your toughest technical questions.  Online Expert Days give you a chance to talk directly with the HPE Experts!

 

How does the Online Expert Day event work? 

HPE Experts will be online for 24 hours in the forum and will do their best to answer your questions. They may need to get some more information from you so please check the box "email me when someone replies".  An online conversation will be born!

 

To participate, you do need access to the UCMDB and UD Support Customer Forum if you don’t have access, please add your Support Agreement ID (SAID) to your HPE Passport profile and log in again.

To check this please do the following:

 

If you have a valid support contract and are still experiencing issues after checking it or adding it, please send an email to swcommunity@hpe.com.

For more information on our Support Customer Forums and how to add your Support Agreement ID (SAID) to your HPE Passport profile, please click here.

For upcoming Online Expert Days, please bookmark the HP Software Online Support Services - Forum events page.

 If you have questions regarding the Online Expert Day event, please reply to this message.

We look forward to your attendance and your questions!

Regards,

HPE Support

 

how to install ucmdb 10.32Open in a New Window

Hi All,

I need to install ucmdb 10.32. How to download 10.32 version. I searched in HPE I am able to find 10.30 only.

Do i need to install 10.30 first and then patch for 2 version?

where to find patches?

 

Regards,

Kumar

 

Setting up Call Home For UDAOpen in a New Window

It has been a while since this thread was discussed, but we're just moving from DDMi to UD.  Our UD environment only discovers end user devices, and we will have UD Agents on all of them.

However, we have many users who access via VPN and are trying to get these devices to use the call home feature since we obviously do not have the ip ranges for these.

We also have a limitation that prevents us from using SNMP data collection (not to mention we need to use UDA for software data collection).

We set up our UD environment as Data Center type and can see permanently connected *but DHCP-allocated IP addresses) are sending scan files to the Data Flow Probe.

However, the VPN test machines are not.  Can Call Home be used with the Data Center Type, and what are we missing in order to do this?

>John GOldstein provided this reply already in another thread:

"Your answer depends on the version of UCMDB that you are using. For 10.31 there is a property in globalSettings.xml called allowDataCenterCallhome that you must set to true."

 

UMCBD To Atrium IntegrationOpen in a New Window

Hi Experts,

 

I need to do the integration between ucmdb and BMC Atrium.

I did the basic configuration.Also provided the Remedy protocol but when i am testing the connection in integration point.  I am getting the below error.

com.hp.ucmdb.discovery.probe.request.ProbeSideProcessorException: [ErrorCode [800] Couldn't connect
to Integration{uCMDB to BMC integration, AtriumPushAdapter, ***********}]
Integration[uCMDB to BMC
integration]: com.hp.ucmdb.federationspi.exception.DataAccessCommunicationException: Connection
failed: ('No username and/or target server defined. ',)

--- Start of probe-side exception
---
com.hp.ucmdb.dataAccess.exceptions.AdapterAccessCommunicationException: [ErrorCode [800] Couldn't
connect to Integration{uCMDB to BMC integration, AtriumPushAdapter,
************}]
Integration[uCMDB to BMC integration]:
com.hp.ucmdb.federationspi.exception.DataAccessCommunicationException: Connection failed: ('No
username and/or target server defined. ',)
at
com.hp.ucmdb.dataAccess.exceptions.ExceptionConverter.createAdapterAccessCommunicationException(ExceptionConverter.java:293)
at
com.hp.ucmdb.dataAccess.exceptions.ExceptionConverter.createAdapterAccessException(ExceptionConverter.java:104)
at
com.hp.ucmdb.dataAccess.exceptions.ExceptionConverter.createAdapterAccessException(ExceptionConverter.java:67)
at
com.hp.ucmdb.discovery.probe.processor.FederationNoneLifeCycleProbeProcessor.process(FederationNoneLifeCycleProbeProcessor.java:74)
at
com.hp.ucmdb.discovery.probe.processor.FederationNoneLifeCycleProbeProcessor.process(FederationNoneLifeCycleProbeProcessor.java:27)
at
com.hp.ucmdb.discovery.probe.agents.probemgr.adhoctasks.AdHocProbeRequestOperation.performAction(AdHocProbeRequestOperation.java:64)
at
com.hp.ucmdb.discovery.probe.agents.probemgr.taskdispatcher.AdHocTaskDispatcher.dispatchTask(AdHocTaskDispatcher.java:70)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at sun.reflect.misc.Trampoline.invoke(MethodUtil.java:71)
at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at sun.reflect.misc.MethodUtil.invoke(MethodUtil.java:275)
at
com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:112)
at
com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:46)
at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:237)
at com.sun.jmx.mbeanserver.PerInterface.invoke(PerInterface.java:138)
at com.sun.jmx.mbeanserver.MBeanSupport.invoke(MBeanSupport.java:252)
at javax.management.StandardMBean.invoke(StandardMBean.java:405)
at
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:819)
at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:801)
at
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:292)
at
org.springframework.jmx.access.MBeanClientInterceptor.doInvoke(MBeanClientInterceptor.java:405)
at
org.springframework.jmx.access.MBeanClientInterceptor.invoke(MBeanClientInterceptor.java:353)
at
org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)
at com.sun.proxy.$Proxy81.dispatchTask(Unknown Source)
at
com.hp.ucmdb.discovery.probe.agents.probegw.managementtasks.adhoctasks.AdhocThread.run(AdhocThread.java:54)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
at java.lang.Thread.run(Thread.java:745)
--- End of probe-side exception ---

 

Any help would be appreciable . Thanks in Advance.

 

 

Exclusion list for InstalledSoftware CI'sOpen in a New Window

We are running uCMDB with UD version 10.22. I've been seeing a lot of references to an exclusion list for installed software and wanted to use this to exclude the discovery of Microsoft Updates (KB's and Security Updates). I've seen several references to excluding them from reports but the CI's are still being created and stored in the uCMDB. I'm wanting to know if we can tell the agents to not pass that information up to the probes in the first place.

 

UCMDB 10.21Open in a New Window

I want to know the HP recommended free space availability /threshold for UCMDB to function and  to assure all jobs run proper. 

 

uCMDB 10.3 web service: Getting error "Transport level information does not match with SOAP Messag"Open in a New Window

Hi All

1] I am trying to access uCMDB web service from OO.

2] I have imported uCMDB API in OO using wsdl url and got ready made flow in OO.

Trying to run operation from OO, but getting error as . webservice is confugured on port 8443, same operation works if we swithc webservice over port 8080

{resultText=GENERAL_ERROR;exception=;document=<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsa="http://www.w3.org/2005/08/addressing"><soapenv:Header><wsa:ReplyTo><wsa:Address>http://www.w3.org/2005/08/addressing/none</wsa:Address></wsa:ReplyTo><wsa:MessageID>urn:uuid:852388ECC6523275361489544204695</wsa:MessageID><wsa:Action>http://www.w3.org/2005/08/addressing/soap/fault</wsa:Action></soapenv:Header><soapenv:Body><soapenv:Fault><faultcode></faultcode><faultstring>Transport level information does not match with SOAP Message namespace URI</faultstring><detail/></soapenv:Fault></soapenv:Body></soapenv:Envelope>;returnResult=-1;errorMessage=;httpResult=INTERNAL_SERVER_ERROR;sessionId=;rawXMLRequest=<?xml version="1.0" encoding="UTF-8"?>

 

Please let me know any one know solution for this issue

 

upload attachment to ucmdbOpen in a New Window

Hi,

How to upload floor plan .vsd files to ucmdb? please advice

Thanks in advance

 

 

Enrichment Rule for Physical Rack LocationsOpen in a New Window

Hello,

We are setting an Attribute "Physical Rack Notes"​ for Node CIs ,

in case if it sees the attribute as SC-24 an Enrichment Rule should relate this Node CI to Rack CI SC-24.

(if Match Physical Rack Notes Attribute with Name of Rack CI)

if the value for Attribute "Physical Rack Notes"​ is Null (No Value) , then it should delete the relationship to the Physical Rack CI from that node CI.

If the value for Attribute "Physical Rack Notes"​ is not matching, then it should delete the relationship to the Physical Rack CI from that node CI.

So 3 Enrichment Rules for these, (planning to run on demand not scheduling it)

 

I am Planning Usage Relation from Rack CI to the Node CI. Your thoughts please.

 

Sample Query would be great.

 

 

 

 

Filesystems required for UCMDB 10.30 Installation on Linux MachineOpen in a New Window

Hi All,

I am installing 10.30 ucmdb version in linux environment.

Can any one guide me what exact flie systems need to created in unix for UCMDB.

And also which is the filesystem used as data repository.

Regards,

Kumar

 

Upgrade embedded PostgreSQL database on probeOpen in a New Window

Hi,

For security vulnerabilities, our customer doesn't like the current PostgreSQL version on probe (9.2.2, supported for 10.2* version of UCMDB).

Do you know if it can be upgraded? I am almost sure the answer is no, as it won't be supported.

The only other option we found is to upgrade to UCMDB 10.30, as the PostgreSQL version supported is 9.4.8.

Thanks,

Paulina.

Contact Us

Vivit Worldwide
P.O. Box 18510
Boulder, CO 80308

Email: info@vivit-worldwide.org

Mission

Vivit's mission is to serve
the Hewlett Packard
Enterprise User
Community through
Advocacy, Community,
and Education.