HPE Software Products: ITRC ProLiant Deployment and Provisioning Forum
Share |

Can`t set boot device by ipmitool on ProLiant DL380 G7Open in a New Window

 ipmitool -I lanplus -H -L ADMINISTRATOR -U ironic -R 12 -N 5 -P ***** chassis bootdev disk options=persistent
Set Boot Device to disk

 ipmitool -I lanplus -H -L ADMINISTRATOR -U ironic -R 12 -N 5 -P **** chassis bootparam get 5
Boot parameter version: 1
Boot parameter 5 is valid/unlocked
Boot parameter data: 0008000000
 Boot Flags :
   - Boot Flag Invalid
   - Options apply to only next boot
   - BIOS PC Compatible (legacy) boot
   - Boot Device Selector : Force Boot from default Hard-Drive
   - Console Redirection control : System Default
   - BIOS verbosity : Console redirection occurs per BIOS configuration setting (default)
   - BIOS Mux Control Override : BIOS uses recommended setting of the mux at the end of POST

But node still tries to boot from NIC, it get adress from DHCP and fails to boot.


Adding licence to Insight Control Server ProvisioningOpen in a New Window


I undertans that ICsp comes fully licenced with HPE OneView - can anyone tell me how the licence is obtained?

Do I just apply the same licence I do for the each OneView client or should I be able to get an ICsp activation key from somehwere?


thanks in advance


Insight Control Provisioning server boot blade into Service OS and use static IP address.Open in a New Window


I'm having issues booting a HPE blade server into the service OS as I don't think the server can pick up a DHCP address. Is there a way that I can configure it with a static IP address?

thanks in advance


ICsp 7.6 fails to boot into Maintenance OS - Wait for HP SA Agent failed with exit code 120Open in a New Window


I'm new to ICsp and just trying to set it up to work with a few HPE Gen9 blades in a c7000 chassis with Virtual connect (controlled by OneView). I've installed the ICsp Appliance (on a standalone ESXi host) and also built a Windows vm as an ICsp Media Server. 

So I'm at the stage of wanting to add the bare metal blade servers into the ICsp Appliance so I can deploy VMware ESXi 6.5. I select the Add Server option and give it the iLO address and login credentials and all this is fine but it failed to boot into the Maintencance OS as it fails to complete step 4 and times out saying "Failed to wait for the HP SA Agent: The agent did not appear on the network (is not listening on its port)."

I suspect this is a networking issue but not sure how to troubleshoot this. 

How does the Appliance try to connect to the SA agent? 

The blades are installed with FLB650 flex fabric adapters which will give the blade a total of 8 nics - Is the appliance expecting 1 or all these nics to get an IP address through DHCP and trying to connect through that? As I don't think DHCP is working correctly yet?

I have set up DHCP on the Appliance but can't tell if it's issues any addresses yet - is there a way to tell if it's issued an address to a server? I'm certain this will be something to do with networking but am hoping I can get a bit of an insight as to what I need to tell our networking team what needs to happen for the Appliance to be able to conect the SA Agent.

thanks in advance for any info



ICSP WinPE not registering on ICSP serverOpen in a New Window

I am trying to provision Windows server when it boots into Windows ServiceOS, it is not able to communicate to ICSP server. It seems it is unable to get the HPSA gateway and port

Running ICSP 7.6, Installing Any Windows version


ICSP - Is it possible to filtering server-hardware by MAC addressOpen in a New Window

Hello, I am working on certifiying ICSP for our build process and wanted to know is it possible to get a blade in ICSP based off of a MAC address? We will have a portal that sends our build server a MAC address and will need to convert the MAC address into the correct blade as we will send it additional information like OS, configuraiton, etc.

Thank you.


HP SUM Error - Unable to login or identify node as a supported deviceOpen in a New Window

I am running HP SUM 7.5.1 on CentoOS 7.

I can add Nodes for iLO and VMware and update firmware with no issues.

When I add a Windows Node I get an error on the initial inventory -

Unable to login or identify node as a supported device.

Unable to identify node as a supported node type. Please ensure that node is supported, reachable on the network and credentials are correct.

Credentials are correct and Windows Security log confirms that the authentication was successful.

Any ideas?  I have scoured google and tried countless variations of the configuartion.

Thanks in advance.


Scripting Toolkit (stk) 10.40 bootstrap.sh ends with errorOpen in a New Window

I am looking for support for the HPE Scripting Toolkit 10.40. I am booting a BL460c Gen8 server and can pxe boot the kernel and the built-in bootstrap.sh does execute.  However, it ends however with the messages:

*****include file not found*****
bash: cannot set terminal process group (-1) inappropriate ioctl for device

bash: no job control in this shell

  I am trying to use nfs to mount the scripts folder.  Once the bootstrap.sh stops, the folder is not mounted but I can mount it manually from the command line.  I suspect I may have some options set incorrectly in the pxelinux.cfg but I have ran out of ideas and am fairly new to Linux.  Any direction would be most appreciated.




HPSUM CLI Error cannot parse the option when run from UNC network share pathOpen in a New Window

Hi Folks,

I want to add a HPSUM CLI script to run update after OS deployed. I call HPSUM.bat from UNC path but it show error about "cannot parse the option".  

\\hpsumserver\c$\Repository\hpsum /use_latest /allow_non_bundle_components /allow_update_to_bundle /use_location "\\hpsumserver\c$\Repository"
Error: cannot parse the option: /use_latest.
Use 'hpsum /help' for more details on command syntax.

Thanks in Advance,



OS Build Plan - ESXi 6.0 fails with "User-supplied %post script failed . (Error code 256)Open in a New Window

I am facing an error deploying an esxi6 hp custom image (builds 3073146,3380124) using the builtin os deployment plan. The error message is "User-supplied %post script failed. (Error code 256)"

Everything looks good until the point where the post section of the kickstart file is processed. I completely removed the post section from the kickstart file and still get the same error. So i logged in via the console and noticed that another post section is created by the deployment process. Interestingly the generated commands dont´t generate an error.

Does anybody else experience the same behaviour?





SUM 7.4.0 - HP Insight Management Agents for Windows Server x64 Editions (cp026785) SNMP ErrorOpen in a New Window


Our company is running Windows 2008 Server R2 Standard EN-US on a HP ProLiant DL360 G7 Server. When using HP Smart Update Manager (SUM) 7.4.0 to install the latest drivers and software, I've the following error for "HP Insight Management Agents for Windows Server x64 Editions (cp026785)": Failed dependency SNMP service (cf screenshots in attachment). Therefore, I can't deploy this update. As a result, there's no data in HP System Management.

Note that I did the exact same updates with HP SUM 7.4.0 on another Windows 2008 Server R2 Standard EN-US running on a HP ProLiant DL360 G7 Server and it worked, the cp026785 package was successfully installed.

Can someone help me to solve this issue? I can't figure out what's the root cause. The error message is too simple. What SNMP service is invloved? I tried to start the SNMP Trap service in Windows (services.msc) but it didn't solve anyhting.

Thanks for your help.


Smart update Manager - Run as Windows ServiceOpen in a New Window

Is it possible to run the HP Smart Update Manager as a Windows Service so that its always running and maintains it's state i.e. device invetoried etc. 


HPSUM as a windows serviceOpen in a New Window

Is it possible to run HPSUM 7.3 as a windows service on a single server i.e. so we could have it always running and connect to it remotely to inventory other servers et


socket error 10013 when starting hpsum on 2008r2Open in a New Window



I try to run the latest HPSUM version SPP2015060. I downloaded the iso file and extracted it's contents to an folder on the server. When running the launch_hpsum.bat i receive the following error message:


Error: Cannot launch hpsum_service_x64.exe locally. Reason: General failure. (SocketError 10013 : Er is geprobeerd toegang te verkrijgen tot een socket op een volgens de toegangsmachtigingen niet toegestane manier.


The last message is un dutch but translates to something like: An attempt was made to access a socket with a properly access permissions unauthorized way

I disabled the trendmicro antivirus, firewall etc. but this message keeps me from running the support pack.


Also tryed to run with elevated rights but still the same message ....


OS is Windows 2008r2

Server is : proliant ML110 G7

4Gb ram and plenty of free disk space


When trying to run hpsum 7.30 i have the same result, PSP 9.10 crashes the complete server during inventory of CP010988.


Does anyone know how i can get the server updated using any of these methods ?



Smart Update Manager 7.2.0 hung in ScoutingOpen in a New Window

After discovering all nodes in four ranges (four subnets, so each is x.x.x.1 to y.y.y.255), 100 nodes are found, many OA and iLO are identified and in "Ready to start inventory", but some nodes are UNKNOWN and in "Scouting" overnight (over 17 hours).


With nodes in Scouting, SUM refuses to shutdown. Since it seems unlikely these wil ever complete, should I fource the SUM engine to exit?


I'm running SUM from Service Pack for Prolaint 2015.04 under Windows 7 in a VM.


HP SUM run as a service or HP SIM?Open in a New Window



I use HP SUM that comes in the HP SPP to push drives and firmware to new servers.  Having many HP servers deployed (mix of DL and BL server), I would like to find a way to centrally manage, inventory, and deploy drivers and firmware to servers to have a consistent baseline across all hardware.  Right now it's adhoc deploy latest SPP to new servers and when the next server get's built and another SPP gets released, multiple versions exist in our environment.


HP SUM in the SPP works very well and I was wondering if there was a way to install or deploy HP SUM as a service where anyone who deploys a new server can log into the web interface from their own system without having to go to the server where HP SPP exists?  In a perfect world, I would like HP SUM to act like HP SIM where anyone with access can log into an interface and manage software similar to HP SUM but without having to launch the batch file to fire up the HP SUM instance.  I would almost like HP SUM to install as a service on a server so it is always online and serving up the management web page.


I have also played with HP SIM which provides the central management aspect but it seems older and hader to use when all I want to do is centrally manage and view software baselines accross hardware.  Is this the better way to go?


Also, what product is newer or better to use, HP SUM or HP SIM?  I can't tell if HP SIM is being phased out since the interface hasn't changed at all compared to HP SUM.


Sorry if the questions seem dumb.  I'm trying to get a handle on the best process for updating servers and keeping them updated.  


Thanks in advance!!


Scripting Toolkit 10.20 over PXE/NFSOpen in a New Window


Anyone knows when the next version gets released? Current version 10.20 seems to be a bit broken, at least its Linux branch is as I'm unable to boot it up properly over the network:

- init script tries to call netconfig.sh and mount_url.sh wrong path (bin vs sbin)
- it seems kernel lacks NFS support or it's broken

Previous version seems to be fine.

(It seems something bad happen during release as HPSUM 7.3.0 seems to have its own flaws unlike its previous version as well as SPP 2015.06.0, but that's a different story; all released about the same time)

Best regards




HP SUM v7.2.0Open in a New Window



I'm trying to download the latest version of HP SUM (7.2.0) to run on my Windows 8 workstation.


The download page only shows 7.1.0 available as a ZIP for download. 


I downloaded the ISO to use on each server in Offline mode from a USB key, and I can see that it is 7.2.0.  --  but how do I get the 7.2.0 ZIP for my workstation?





ESXi 5.5U2 installation repeatsOpen in a New Window

Hello folks,


I am installing ESXi 5.5 U2 OS Build plan on my BL460c Gen9 blade server and the installation gets to step 19 of 20 and the ESXi installation repeats.


I read in the troubleshooting section that this could be because of multiple local disks available.

However, I have already set my server profile local storage to RAID 1, bootable, and updated that.


Any suggestions for how to correct?




ICSP and deploying server on differnet subnetsOpen in a New Window


I'm installing ICSP 7.4  and it works with G6,G7,Gen8, Gen9 if ICSP server is on the same subnet as the deployings servers.

If I set the deploying server on another subnet differnet from the ICSP , it only works with G6,G7,Gen8, NOT GEN9.

I use "iphelper" to point to the ICSP-server.

What have i missed?

Contact Us

Vivit Worldwide
P.O. Box 18510
Boulder, CO 80308

Email: info@vivit-worldwide.org


Vivit's mission is to serve
the Micro Focus User
Community through
Advocacy, Community,
and Education.